Перейти к содержимому


× Быстрый вопрос
Пользователь месяца
Olya23 Olya23 1-й за Июнь
Очков активности: 1 278 3 темы, 133 сообщения, 6 баллов репутации
ТОП самых активных за этот месяц
  • Фотография web-coder
    #1

    web-coder (good-hoster.ru)
    Очков активности: 1147.5 0 тем, 85 сообщений, 9 баллов репутации

  • Фотография Андрей WPMasterKZ
    #2

    Андрей WPMasterKZ (wpmaster.kz)
    Очков активности: 931.5 2 темы, 63 сообщения, 9 баллов репутации

  • Фотография Rodiola
    #3

    Rodiola (rukodelkovo.ru)
    Очков активности: 396 1 тема, 85 сообщений, 3 балла репутации

  • Фотография maxnik
    #4

    maxnik (konovalovpavel.ru)
    Очков активности: 153 0 тем, 34 сообщения, 3 балла репутации

  • Фотография Megoydagi
    #5

    Megoydagi (24ho.ru)
    Очков активности: 150 4 темы, 13 сообщений, 4 балла репутации

  • Фотография FIvYUr
    #6

    FIvYUr (moy-evroopt.ru)
    Очков активности: 108 1 тема, 33 сообщения, 2 балла репутации

  • Фотография BLIK
    #7

    BLIK
    Очков активности: 85.5 Вне конкурса за определение пользователя месяца

  • Фотография lena220678
    #8

    lena220678
    Очков активности: 70.5 4 темы, 35 сообщений, 1 балл репутации

  • Фотография Olya23
    #9

    Olya23
    Очков активности: 45 Вне конкурса за определение пользователя месяца

  • Фотография katti8907
    #10

    katti8907
    Очков активности: 30 3 темы, 11 сообщений, 1 балл репутации

  • Показать весь ТОП 10
Поддержите форум! =)
Апдейты
  • Яндекс ИКС: 25.06.2019
  • Яндекс выдача: 21.07.2019
Топ 5 участников по репутации


Нужна помощь с гифками

#1 magnet

magnet
  • Пользователь PRO
  • 1 750 сообщений
  • Репутация: 357
0

Отправлено 11 Март 2019 - 01:13

Сегодня создал категорию гифок и столкнулся с интересной ситуацией... На компе гифки раскрываются живые, как положено, а при публикации на сайте они через одну рабочие, а остальные тупо пассивные фотки... От того, что они на компе раскрываются как положено, это вводит меня в стопор((

Кто то имеет подобный опыт, в чем может быть проблема?


 

 

  • 0


#2 magnet

magnet
    Topic Starter
  • Пользователь PRO
  • 1 750 сообщений
  • Репутация: 357

Отправлено 11 Март 2019 - 02:22

Пока разбирался, пришел к выводу, что проблема воспроизведения гифки была в размере ( ширина )  и это скорей проблема в настройках шаблона... Пока не все ясно, нужно разбираться)

 

В любом случае, любые советы по гифкам будут полезны!


  • 0


#3 Artos

Artos
  • Пользователь
  • 92 сообщений
  • Репутация: 9

Отправлено 11 Март 2019 - 13:21

Скорей всего так.

В настройках сайта задан макс размер картинок. Если загружаемые картинки размером больше, чем задано, то скрипт уменьшает картинку, причём, только первый кадр, а остальные кадры отбрасывает и анимация пропадает. Если загружаемый размер не больше заданного, то загружается как есть, без переделки, и анимация, естественно, будет работать.

В php, кажись, нет функции для работы с картинками по кадрам. Можно обрезать картинки дома до копирования на сайт, например, при помощи ImageReady.


Сообщение отредактировал Artos: 11 Март 2019 - 13:28

  • 1

#4 Андрей WPMasterKZ

Андрей WPMasterKZ
  • Пользователь
  • 782 сообщений
  • Репутация: 103

Отправлено 11 Март 2019 - 13:56

Поддерживаю версию @Artos, проблема в миниатюрах, создаваемых либо самим движком, либо темой.

 

P.S.: У меня сейчас в подписи статья про хуки, там есть скрипты с помощью которых сможешь создавать собственные размеры и отключать базовые.


Сообщение отредактировал Андрей WPMasterKZ: 11 Март 2019 - 13:59

  • 0


#5 magnet

magnet
    Topic Starter
  • Пользователь PRO
  • 1 750 сообщений
  • Репутация: 357

Отправлено 11 Март 2019 - 14:52

С размерами я разобрался, гифки подгоняю под нужные параметры. А вот как сделать, что бы при добавлении изображения к статье в анонсе, гифка не превращалась в фото не пойму(


  • 0




Похожие темы

  Название темы Автор Статистика Последнее сообщение

Оформление форума – IPBSkins.ru