Перейти к содержимому

Сервис обмена электронных валют

Выбрать шаблон и создать сайт

Лишние символы при выводе

#11 ruslan_kolesnyk

ruslan_kolesnyk
    Topic Starter
  • Пользователь
  • 8 сообщений
  • Репутация: 0
0

Отправлено 02 Февраль 2012 - 00:00

Вот и практически докопались до причины. На сервере не обрабатывается код PHP. Что за сервер используется? Где исполняется код?


Денвер, пробовал во всех браузерах. Если php не обрабатываеться, то почему при вводе этого:

<html><body>

<?php

echo "<p>hello</p>"
?>

</body></html>


Получаеть такое:

hello

" ?>


  • 0

#12 matroskin8

matroskin8
  • Пользователь PRO
  • 767 сообщений
  • Репутация: 143

Отправлено 02 Февраль 2012 - 00:35

Сохрани этот же код в документе на рабочем столе (где не обрабатывается серверный код)... неважно с каким расширением - index.php или index.html... открой документ в браузере - удивишься, но получишь тот же результат:

hello

" ?>

По теме... На Денвере с каким расширением сохранен файл и по какому адресу идет к нему обращение?
  • 0


#13 surfer

surfer
  • Заблокированные
  • 1 956 сообщений
  • Репутация: 71

Отправлено 03 Февраль 2012 - 11:59

создай файл info.php
следующего содержания:

<?php
phpinfo();
?>


и посмотри, что выводится в брузере при его просмотре
  • 0

#14 Kuchuluk

Kuchuluk
  • Пользователь
  • 315 сообщений
  • Репутация: 5

Отправлено 05 Февраль 2012 - 11:07

Денвер, пробовал во всех браузерах. Если php не обрабатываеться, то почему при вводе этого:



Получаеть такое:

после оператора echo точку с запятой поставь
  • 0


Оформление форума – IPBSkins.ru