Перейти к содержимому



Заставить css корректно работать в ie на главной странице

#1 myrka

myrka
  • Пользователь
  • 22 сообщений
  • Репутация: 10
0

Отправлено 14 Январь 2012 - 19:57

Здравствуйте. Помогите пожалуйста понять в чём же дело. При открытии сайта в браузере IE не плывёт вёрстка, причём не отображаются картинки (там, где отображается путь в CSS) в остальных браузера стартовая страница открывается как надо, что самое интересное, когда лазишь по другим ссылкам, картинки которых не было видно, становятся видны и вообще CSS отображается как и требовалось, а если возвращаешься на главную, всё опять тоже самое. Подскажите как выйти с этой ситуации…

 

 

  • 0

#2 HapkomaH

HapkomaH
  • Пользователь
  • 38 сообщений
  • Репутация: 2

Отправлено 14 Январь 2012 - 22:36

Скорее всего пути к картинкам указаны неправильно. Попробуйте прописать пути в виде url(/images/img.jpg) или даже полный путь в виде url(http://site.com/images/img.jpg).
  • 0

#3 myrka

myrka
    Topic Starter
  • Пользователь
  • 22 сообщений
  • Репутация: 10

Отправлено 15 Январь 2012 - 00:36

Дело не в этом. почем то когда на другой страничке подключение к тому же CSS, все картинки и вёрстка не плывёт. и если были пути не верные, то думаю во всех браузерах была бы проблема.


  • 0

#4 HapkomaH

HapkomaH
  • Пользователь
  • 38 сообщений
  • Репутация: 2

Отправлено 15 Январь 2012 - 00:50

Это только предположение. Вы бы хоть ссылку дали, чтобы можно было пощупать и понять.


  • 0


Оформление форума – IPBSkins.ru