Перейти к содержимому

Реферальная программа Мегаплана


Помогите с компонентом Linkr

#1 xilgiz

xilgiz
  • Пользователь
  • 155 сообщений
  • Репутация: 0
0

Отправлено 21 Апрель 2011 - 07:31

У меня не работает этот компонент....пробовал разные версии устанавливать
Пишет Deprecated: Assigning the return value of new by reference is deprecated in Z:\home\localhost\www\kazan-site\administrator\components\com_linkr\admin.linkr.php on line 45
Искал такую ошибку, не нашел....помогите пожалуйста...
Когда я нажимаю на иконку, открывается, но потом начинает тормозить, и стоит так

 

 

  • 0

#2 Игорян

Игорян
  • Пользователь
  • 296 сообщений
  • Репутация: 10

Отправлено 21 Апрель 2011 - 11:52

xilgiz, ну вы вобЧе интересный человек ;) , в двух словах хотя бы опишите куда этот компонент, для какого движка и т.д…

Судя по "administrator\components\" это joomla, для начало откройте файл admin.linkr.php и посмотрите что у вас там на 45 строке.
  • 0

#3 xilgiz

xilgiz
    Topic Starter
  • Пользователь
  • 155 сообщений
  • Репутация: 0

Отправлено 21 Апрель 2011 - 21:47

Ну да, на Joomla! Так же называется имя раздела ;)
Может у кого нибудь такое уже было с этим компонентом...
  • 0

#4 surfer

surfer
  • Заблокированные
  • 1 956 сообщений
  • Репутация: 71

Отправлено 21 Апрель 2011 - 22:04

что значит не работает? когда перестал работать? что делал, после чего перестал работать?

а если не поленишься и поищешь в Гугле то эта ошибка появиласть в php 5.3 предупреждающая, что эти функции неиспользуются и будут отключены в будущих релизах
http://php.su/php/?migration53
http://php.net/manua....deprecated.php
  • 0

#5 xilgiz

xilgiz
    Topic Starter
  • Пользователь
  • 155 сообщений
  • Репутация: 0

Отправлено 21 Апрель 2011 - 22:27

Как уже писал, когда нажимаю на иконку linkr внизу текста в менеджера материалов, открывается окно, но если я там нажимаю куда нибудь(хочу найти файл например), он у меня просто грузится, и стоит...ничего не делает....
В яндексе искал ошибку, не нашел про ссылку Linkr
  • 0

#6 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 22 Апрель 2011 - 13:07

xilgiz, совместимость версий проверяли прежде чем ставить? Вообще ошибка, которую вы указали, это не ошибка, а предупреждение. Это предупреждение сообщает, что метод возвращать из функции объект по ссылке устарел, т.к. это сейчас делается без указания & ;) Данное предупреждение никак не влияет на работу скрипта, дело в чем-то другом. Почитайте по интернету, работает ли у кого-нить этот Linkr, а прежде чем скачивать, нужно было почитать коменты на страничке. Часто компоненты модифицируют и об этом не сообщают, а после этого они перестают работать. Качайте компонент с оффициальных источников.
  • 0

#7 xilgiz

xilgiz
    Topic Starter
  • Пользователь
  • 155 сообщений
  • Репутация: 0

Отправлено 22 Апрель 2011 - 13:34

Совместимость вроде нормальная)))) у меня 1.5.23
Я тоже стараюсь читать комментарии я установил версии 2.3.5 2.3.4 и 2.3.6
И во всех та же фигня была....адно, сейчас еще пару скачаю, и попробую переустановить....
  • 0

#8 xilgiz

xilgiz
    Topic Starter
  • Пользователь
  • 155 сообщений
  • Репутация: 0

Отправлено 22 Апрель 2011 - 14:14

не....установил 2.3.7, там не выдает "ошибок", но так же стоит, и грузится.......
Я смотрел видео, там нажимали, например на кнопку файл и искали файл, куда ссылаться,
а я нажимаю, у меня так и стоит...просто грузится....А нет на подобии компонентов? таких же удобных
  • 0

#9 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 23 Апрель 2011 - 16:47

xilgiz, у вас lightbox всплывает, но в нем ничего не отображается. Так? Если сайт в инете кидайте в ЛС ссылку и доступ к админке, попробую помочь.
Может проблема в том, что вы установили только часть Linkr, он состоит из компонента, модуля и кнопки. Я установил Linkr 2.3.7, всё работает:
http://joomlacode.or...aller_2.3.7.zip

Удалите все старые компоненты и плагины Linkr и поставьте все заново.
  • 0

#10 xilgiz

xilgiz
    Topic Starter
  • Пользователь
  • 155 сообщений
  • Репутация: 0

Отправлено 29 Апрель 2011 - 07:59

ZiTosS, Скачал со ссылки, то же самое.
Да, окошко всплывает, показывает только названия меню, если нажать на плюсик, то начинает грузиться, и так стоит...
Пробовал на разных сайтах разные версии, может joomla попробовать поменять...
Это на локалке
  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85


Оформление форума – IPBSkins.ru