Перейти к содержимому



  • Закрытая тема Тема закрыта

Теги h и Эксплорер 9

#1 lesli007

lesli007
  • Пользователь
  • 108 сообщений
  • Репутация: -4
0

Отправлено 29 Март 2011 - 12:45

PHP
 <?php 
if ($myrow['text']== "")
{echo "<p id='otstup'>Биография исполнителя находится в разработке.</p>";}
else
{echo "<h3>Немного о $myrow[name]</h3><div id='otstup'>$myrow[text]</div> <br><div align='right' id='index_release'><a href='view_biography.php?id=$myrow[id]' class='index_release'><em>Полная биография >></em></a></div>";
}?>


CSS
h3 {
font-size:16px; 
font-family:Arial, Helvetica, sans-serif; 
margin-left:30px;
}
Проблема в отображении h3 и вообще тегом h в explorere. У меня версия 9. В других браузерах все отображfется корректно. В эксплоере в коде запись присутствует но реально не отображается.

 

 

  • 0

#2 surfer

surfer
  • Заблокированные
  • 1 956 сообщений
  • Репутация: 71

Отправлено 29 Март 2011 - 12:58

когда вы научитесь правильно задавать вопросы?
и при чем здесь php?
тему перенес, оформляйте правильно код.
  • 0

#3 Symphony

Symphony
  • Пользователь
  • 636 сообщений
  • Репутация: 54

Отправлено 29 Март 2011 - 13:08

винду лицензионную мб надо ? на крайняк обновите ишака9, мб вирус файлик какой-нить съел
  • 0


#4 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 29 Март 2011 - 13:27

lesli007, Может быть вся проблема в использовании вами в тексте спецсимволов.
Полная биография >>
Теги < и > используются в HTML только для формирования тегов и ничего другого. Если вам нужно использовать данные символы на странице в тексте, используйте их эквиваленты:
< - &lt;
> - &gt;

  • 0

#5 surfer

surfer
  • Заблокированные
  • 1 956 сообщений
  • Репутация: 71

Отправлено 29 Март 2011 - 21:29

думаю ТС необходимо изучить основы php прежде чем браться за написание кода, например это
http://www.php.su/le...tatypes/?string
http://www.php.su/le...atypes/?string2
http://www.php.su/le...atypes/?string3
http://www.php.su/le...atypes/?string4
  • 0

#6 lesli007

lesli007
    Topic Starter
  • Пользователь
  • 108 сообщений
  • Репутация: -4

Отправлено 29 Март 2011 - 22:20

lesli007, Может быть вся проблема в использовании вами в тексте спецсимволов.

Полная биография >>
Теги < и > используются в HTML только для формирования тегов и ничего другого. Если вам нужно использовать данные символы на странице в тексте, используйте их эквиваленты:
< - &lt;
> - &gt;

В коде &gt;&gt; стоит, здесь почему-то отобразилось так.
  • 0

#7 lesli007

lesli007
    Topic Starter
  • Пользователь
  • 108 сообщений
  • Репутация: -4

Отправлено 30 Март 2011 - 19:37

surfer, слушай, имитатор сервера! Давай ты вот если можешь что то сказать по теме то говоришь! Если не можешь то сиди в стороне пока хорошие люди типа Администратора, Symphony и ZiTosS (особая благодарность за всё) помогают разбираться во встречающихся сложностях в PHP. Хочу напомнить тебе, что ФОРУМ это место где просят помощи и дают помощь. А ты ведешь себя борзо и от твоих комментариев ноль толку.
  • 0

#8 Игорян

Игорян
  • Пользователь
  • 296 сообщений
  • Репутация: 10

Отправлено 30 Март 2011 - 20:03

ага, задал вопрос по html иди на htmlbook, задал вопрос по php иди на php.ру задал вопрос по java, не ну ты не наглей, беги на javascript.ру и изучай там основы потом придеш сюда :) , для чего тогда форум? ;) Если нет желания помочь, думаю само правильно промолчать, чем отправлять людей на тематические ресурсы, то они без вас ни знают куда им идти и что изучать.
  • 0

#9 FaTeRy

FaTeRy
  • Пользователь
  • 480 сообщений
  • Репутация: 1

Отправлено 30 Март 2011 - 20:38

PHP

 <?php 
if ($myrow['text']== "")
{echo "<p id='otstup'>Биография исполнителя находится в разработке.</p>";}
else
{echo "<h3>Немного о $myrow[name]</h3><div id='otstup'>$myrow[text]</div> <br><div align='right' id='index_release'><a href='view_biography.php?id=$myrow[id]' class='index_release'><em>Полная биография >></em></a></div>";
}?>


CSS
h3 {
font-size:16px; 
font-family:Arial, Helvetica, sans-serif; 
margin-left:30px;
}
Проблема в отображении h3 и вообще тегом h в explorere. У меня версия 9. В других браузерах все отображfется корректно. В эксплоере в коде запись присутствует но реально не отображается.

Не вижу с ходу в чём может быть ошибка, но попробуйте поменять шрифт или убрать левый отступ. Если всё равно ничего не изменится - попробуйте задавать этот текст не через h, а через независимый класс.
  • 0

#10 Игорян

Игорян
  • Пользователь
  • 296 сообщений
  • Репутация: 10

Отправлено 30 Март 2011 - 21:01

Покажите весь код страници, тут можно раставить маркеры %s и попробовать
  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85


Оформление форума – IPBSkins.ru