Перейти к содержимому


Партнерская программа Kredov

  • Закрытая тема Тема закрыта

Как задать количество колонок?

#21 MIKEFM

MIKEFM
    Topic Starter
  • Пользователь
  • 19 сообщений
  • Репутация: 0
0

Отправлено 01 Апрель 2011 - 13:19

понял )
так я уже так делал, но потом фигня выходила.. щас ещё попробую
  • 0

#22 surfer

surfer
  • Заблокированные
  • 1 956 сообщений
  • Репутация: 71

Отправлено 01 Апрель 2011 - 13:20

в чем выражалась фигня?
  • 0

#23 MIKEFM

MIKEFM
    Topic Starter
  • Пользователь
  • 19 сообщений
  • Репутация: 0

Отправлено 01 Апрель 2011 - 13:25

не помню уже точно, но вроде как сайт просто не открывался...
  • 0

#24 MIKEFM

MIKEFM
    Topic Starter
  • Пользователь
  • 19 сообщений
  • Репутация: 0

Отправлено 01 Апрель 2011 - 13:39

обновился.
и опять, када захожу в плагины та же фигня...

Fatal error: Access level to PluginsModelPlugins::_getList() must be public (as in class JModel) in /home/wmdaec/domains/lp-land.com/public_html/administrator/components/com_plugins/models/plugins.php on line 20
  • 0

#25 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 01 Апрель 2011 - 21:38

MIKEFM, компонент такой и вправду есть в папке компонентов админ-панели. Но содержимого, которое выдавало бы ошибку, как у вас я там не обнаружил. У вас выдается ошибка:

Fatal error: Access level to PluginsModelPlugins::_getList() must be public (as in class JModel) in /home/wmdaec/domains/lp-land.com/public_html/administrator/components/com_plugins/models/plugins.php on line 20

сообщающая, что доступ к методу _getList() вне класса PluginsModelPlugins (наследованный от JModel) запрещен. Для доступа к методу модификатор доступа у него должен быть public.
Короче, криво написан компонент, не знаю, может вы его меняли... кто знает. Прикладываю в аттаче свой родной компонент com_plugins с чистой Joomla 5.1.22
Сделайте страховочную копию своей папки com_plugins, затем удалите папку com_plugins и залейте мою приложенную. Ошибка должна пропасть.

Прикрепленные файлы

  • Прикрепленный файл  com_plugins.zip   12,14К   Количество загрузок: 63

  • 0

#26 MIKEFM

MIKEFM
    Topic Starter
  • Пользователь
  • 19 сообщений
  • Репутация: 0

Отправлено 02 Апрель 2011 - 12:51

Всё сделал.. та же фигня. При попытке зайти в менеджер плагинов :
Fatal error: Access level to PluginsModelPlugins::_getList() must be public (as in class JModel) in /home/wmdaec/domains/lp-land.com/public_html/administrator/components/com_plugins/models/plugins.php on line 20

Лучше расскажите мне, как переустановить джумлу, но чтоб при этом вохранились модули, настройки , меню, и материалы
  • 0

#27 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 02 Апрель 2011 - 13:39

MIKEFM, переустановка и восстановление данных не поможет. Косячит как-то из плагинов админ-панели. Сайт где-то лежит или на локалке?
Если где-то в инете расположен, киньте мне в личку доступ к FTP - гляну.
  • 0

#28 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 06 Апрель 2011 - 20:43

Вопрос с компонентом плагинов com_plugins был решен заменой данного компонента из версии Joomla 1.5.22 (тс пытался обновиться до 1.6, не получилось, а часть файлов на место не вернул)
Тема закрыта.
  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85


Оформление форума – IPBSkins.ru