Перейти к содержимому

Сервис обмена электронных валют


  • Закрытая тема Тема закрыта

Не запускается PHPMyAdmin

#1 Tori

Tori
  • Пользователь
  • 35 сообщений
  • Репутация: 0
0

Отправлено 04 Декабрь 2010 - 19:54

Проблемма такая:
У меня установлен Денвер. Все работало нормально, но вчера попыталась установить cервер MySQL (winMySQLAdmin) для MySQL-Front но он не стал работать и я удалила его. Потом при попытке зайти в PHPMyAdmin (localhost/Tools/phpMyAdmin) страница грузится секунд 30, а потом выходится пустая страница :) Пробовала переустанавливать, но все равно PHPMyAdmin отказывается запускаться :)
Что делать?

 

 

  • 0

#2 bumer

bumer
  • Пользователь
  • 502 сообщений
  • Репутация: 0

Отправлено 04 Декабрь 2010 - 21:04

может попробовать все занового установить и в другую директорию папки
  • 0

#3 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 04 Декабрь 2010 - 23:52

Tori, и так-с:
1) Так что вы точно пытались уствновить - сервер MySQL или пакет winMySQLAdmin?
2) Вы не устанавливали кроме данной утилиты ничего к себе на компьютер, например Skype и подобные. Если стоит скайп, попробуйте его отключить и проверить.
3) И скажите пожалуйста, какой сборки у вас PHP 5.2 или 5.3. В инете везде пишут что на сборке денвера-3 с php 5.3 косячит phpMyAdmin.

Сначала ответьте на все мои вопросы. Потом если не придумаем решения. пойдем напролом, попытаемся подключиться к MySQL напрямую. Было бы хорошо посмотреть, что пишется в логи сервера (файл errors.log или что-то подобное где-то в папках сервера).

Такое чувство, что либо MySQL не отвечает...
  • 0

#4 Tori

Tori
    Topic Starter
  • Пользователь
  • 35 сообщений
  • Репутация: 0

Отправлено 05 Декабрь 2010 - 11:38

Установила сервер MySQL 6.0, переустановила Денвер (сборка РНР 5.3) и MyAdmin вошел, но при импорте баз данных русский текст выводится странными символами. Можно это как-то исправить?
Изображение

А при попытке просто вручную ввести русский текст выдает ошубку.
#1366 - Incorrect string value: \'\\xF8\\xEA\\xEE\\xEB\\xE0 ...\' for column \'meta_d\' at row 1
Возможно это из-за этих ошибок. Где их исправить?
Изображение
  • 0

#5 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 05 Декабрь 2010 - 14:23

Tori,

Установила сервер MySQL 6.0, переустановила Денвер (сборка РНР 5.3)

Зачем вы ставите отдельно сервер MySQL? Он идет в сборке с денвером. Не надо ставить 2 базы данных, там нужна тонкая настройка по портам и т.д.

но при импорте баз данных русский текст выводится странными символами. Можно это как-то исправить?

Ваша проблема в кодировках, если смотреть по скрину - узнаю.
Данные помещенные в таблицу - в кодировке windows-1251, сервер БД настроен скорее всего на соединение в кодировке utf-8, сделайте скрин главной страницы phpMyAdmin и пришлите из исходного кода строчку со страницы, где у вас выводятся не в той кодировке данные, она будет примерно такая(или с др. кодировкой):
<meta http-equiv="Content-Type" content="text/html; charset=windows-1251">

Мне важна кодировка стоящая в этом meta-теге.

А при попытке просто вручную ввести русский текст выдает ошубку.
#1366 - Incorrect string value: \'\\xF8\\xEA\\xEE\\xEB\\xE0 ...\' for column \'meta_d\' at row 1
Возможно это из-за этих ошибок. Где их исправить?

где вы вручную добавляете русский текст? И скажите типы полей которые вы используете!

То что изображено на втором скрине не коим образом не связано с ошибками, это просто у вас недоступны дополнительные настройки pma
  • 0

#6 Tori

Tori
    Topic Starter
  • Пользователь
  • 35 сообщений
  • Репутация: 0

Отправлено 05 Декабрь 2010 - 16:29

Удалила сервер MySQL. Теперь при обращении к MyAdmin выдает ошибку в Мозилле (в Опере и Eхplorer опять пустая страница загружается):
#1045 - Access denied for user 'root'@'localhost' (using password: NO)
Connection for controluser as defined in your configuration failed.

Установила сервер но новой: При входе MyAdmin запрашивает логин и пароль. Я ввела root, root, войти удалось.
Изображение

пришлите из исходного кода строчку со страницы, где у вас выводятся не в той кодировке данные, она будет примерно такая(или с др. кодировкой)
А где исходный код?

Типы полей: varchar, text, но когда я пытаюсь вручную исправить эти символы он выдает ошибку
#1366 - Incorrect string value: '\xD0\x9C\xD0\xB0\xD1\x80...' for column 'author' at row 1
  • 0

#7 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 05 Декабрь 2010 - 19:59

Tori,

Удалила сервер MySQL. Теперь при обращении к MyAdmin выдает ошибку в Мозилле (в Опере и Eхplorer опять пустая страница загружается):
#1045 - Access denied for user 'root'@'localhost' (using password: NO)

Это скорее всего было так, потому что после удаления MySQL сервера обращение стало идти к другой СУБД(системе управления базами данных), которая ставится вместе с Denwer. Данная ошибка означает, что подключение к MySQL прошло неудачно из-за неверных данных хоста, логина или пароля. Данные настройки задаются в конфиге phpMyAdmin. Кстати, и после удаления MySQL вам нужно было перезагрузить компьютер.
Из-за чего выдавалась ошибка в FF, а в других белая страница точно сказать не могу, но скорее всего из-за кеша, надо почистить кеш браузера.

Установила сервер но новой: При входе MyAdmin запрашивает логин и пароль. Я ввела root, root, войти удалось.

Какой сервер вы поставили заново? Denwer или MySQL, выражайтесь яснее, иначе мы так и будем ходить от проблемы к проблеме.

Вам бы лучше стоило переустановить денвер, перед этим скинув вашу папку со скриптами во временный каталог и сделать дамп БД.
Ответьте пожалуйста на мои вопросы
  • 0

#8 Tori

Tori
    Topic Starter
  • Пользователь
  • 35 сообщений
  • Репутация: 0

Отправлено 05 Декабрь 2010 - 20:35

Какой сервер вы поставили заново? Denwer или MySQL, выражайтесь яснее, иначе мы так и будем ходить от проблемы к проблеме.

Сервер ставила MySQL.

Вам бы лучше стоило переустановить денвер, перед этим скинув вашу папку со скриптами во временный каталог и сделать дамп БД.

Удалила все и сервер MySQL и Денвер. Переустановила Денвер заново, теперь опять PHPMyAdmin не заходит, пустая страница опять.
  • 0

#9 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 05 Декабрь 2010 - 21:12

Tori, Не торопитесь пожалуйста, больше ничего не удаляйте и не ставьте.
Скажите пожалуйста, каким образом вы удаляли MySQL сервер, через панель управления, "Установка и удаление программ"?
Кстати, вы в денвер 3 поставили автоматическую загрузку сервера или ручную. Если ручной запуск, там должно вылазить консольное окно черное, там печатается состояние подключения к серверу, затем оно пропадает, вот его бы запринтскринить в самый последний момент загрузки. Возможно у вас MySQL сервер не подключается (Не знаю, есть ли такое консольное окно в Денвер 3).
Так же попробуйте почистить кеш браузера. Затем проверьте наличие папки c phpMyAdmin, к которой вы обращаетесь в адресной строке (обычно это tools/phpmyadmin).

Не удаляйте пока больше ничего и не устанавливайте, надо решать проблему такой какая она есть.
  • 0

#10 Tori

Tori
    Topic Starter
  • Пользователь
  • 35 сообщений
  • Репутация: 0

Отправлено 05 Декабрь 2010 - 21:19

Я удаляю через CClener (насколько я знаю это почти то же самое что и через установку и удаление программ)
Черное окно появляется. Там пишется что MySQL сервер не подключен. (Может в конфигурационном файле что-то)
Кеш почистила. Папка phpMyAdmin есть.
  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85


Оформление форума – IPBSkins.ru