Перейти к содержимому



Не показывает сайт + вопрос по Бд. J1.5.7+VM

#1

Поделиться сообщением #1



kocmocivan

kocmocivan
  • Неактивные
  • 99 сообщений
  • Репутация: 0
0

Отправлено 17 Январь 2010 - 14:44

Перенес с одного хоста на другой.
Joomla 1.5.7 + virtuemart 1.1.3
Подправил конфиг.пхп + залил дамп БД.
Сайт начал выдавать ошибку - JError Unable to load Database Driver:zdesplitkamysql
Как оказалось неправильно указал var $host = 'localhost'; а надо было var $host = 'zdesplitka.mysql';
ПОсле этого у всех кроме меня сайт заработал, а у меня все та же ошибка!
Причем сделал очистку кэша в броузерах + перезапустил комп... - не помогает
Сайт запустился к примеру только через рессурс - hideme.ru который что то делает с прокси...

ЧТО ДЕЛАТЬ ЧТОБЫ У МЕНЯ САЙТ ПОКАЗЫВАЛ НОРМАЛЬНО! ?

Второй вопрос по поводу $host = 'localhost'; везде ли надо заменять localhost на zdesplitka.mysql ??
Есть несколько файлов (обычно называющихся misql.php или mysqli,php) находящихся к примеру в
httpdocs\libraries\joomla\database\database , вот часть когда где встречается localhost

$host = array_key_exists('host', $options) ? $options['host'] : 'loaclhost'; 
$user = array_key_exists('user', $options) ? $options['user'] : '';


или
class database extends JDatabaseMySQL 
{
function __construct ($host='localhost', $user, $password, $database='', $prefix='', $offline = true)


Нужно ли менять во всех скриптах с Localhost на zdesplitka.mysql ????

 

 

  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85
Советую обратить внимание на следующее:
  1. Не отображает заказ Joomla 1.5.7+VM 1.1.3
  2. Подскажите хост для J1.5+VM
  3. Разные кодировки на сайте J1.5+VM
  4. Обработка PHP-кода - полученного из базы данных
  5. Сервис вопросом и ответов на сайте

#2

Поделиться сообщением #2



ZiTosS

ZiTosS
  • Неактивные
  • 5 148 сообщений
  • Репутация: 8

Отправлено 18 Январь 2010 - 00:25

ЧТО ДЕЛАТЬ ЧТОБЫ У МЕНЯ САЙТ ПОКАЗЫВАЛ НОРМАЛЬНО! ?

Попробуйте через другой браузер, а вообще скрин приложите, если и сейчас всё так же. У меня сайт открывается...

Не нужно. В первом случае переменной $host присваивают значение $options['host'], если оно присутствует, иначе 'loaclhost'. Которая потом используется в роли хоста MySQL
Во втором случае в определении конструктора класса database, унаследованного от JDatabaseMySQL переменной $host значение по умолчанию(не понятно конечно, оно никогда не будет использоваться...)
  • 0

#3

Поделиться сообщением #3



kocmocivan

kocmocivan
    Topic Starter
  • Неактивные
  • 99 сообщений
  • Репутация: 0

Отправлено 18 Январь 2010 - 09:23

ZiTosS вообще что то странное происходит.
У сайта должен быть ип начинающийся на 212.193.... а у меня , что дома , что на работе ип 77.131.... как их обновить я хз! т.к. вроде уже и кэш почистил в ОПЕРЕ и в мазиле... нефига не помогает!
  • 0

#4

Поделиться сообщением #4



kocmocivan

kocmocivan
    Topic Starter
  • Неактивные
  • 99 сообщений
  • Репутация: 0

Отправлено 18 Январь 2010 - 18:32

ВОпрос решен , если кому вдруг интерестно -
C:\WINDOWS\system32\drivers\etc
Есть файл hosts в котором были написыны IP для моег осайата...
Необходимо было эти строки удалить и все заработало!
  • 0

#5

Поделиться сообщением #5



ZiTosS

ZiTosS
  • Неактивные
  • 5 148 сообщений
  • Репутация: 8

Отправлено 18 Январь 2010 - 19:29

kocmocivan, попробуйте куки так же вычистить старые, возможно проблема в них. Возможно вы не можете достучаться до новых DNS-серверов. Можно попробовать обратиться к провайдеру, описать суть проблемы и сказать, что обращается не к тому IP сервера, скорее всего это старый IP.
Но сначала почистите куки в браузерах по вашему домену.
Читал я как-то про DNS-сервера, что они на разных уровнях кешируют информацию о том, где искать доменное имя. Вот и отсылает по старой. Тут решение - обращение к провайдеру для выяснения проблем.
  • 0


Оформление форума – IPBSkins.ru