Перейти к содержимому

Сервис обмена электронных валют


Артефакты на картинках при использовании Ява-скрипт. Помогите!

#1 Алексей Соколов

Алексей Соколов
  • Пользователь
  • 4 сообщений
  • Репутация: 0
0

Отправлено 04 Июнь 2009 - 10:04

Всем привет.

Никак не могу понять причину появления светящихся точек на некоторых фотографиях, когда из них сделано слайд-шоу на яве скрипт. Может кто-нить подскажет в чем причина? В браузере Firefox такого не наблюдается, а вот ИЕ - есть.

точки можно увидеть на страничке http://www.wedstory.ru/index_1.htm

С уважением, Алексей.

 

 

  • 0

#2 Евгений

Евгений
  • Пользователь
  • 481 сообщений
  • Репутация: 0

Отправлено 04 Июнь 2009 - 10:16

светящихся точек я не заметил, заметил просто белые пиксели.
а еще больше заметил жжжжжуууткие тормоза.....

скорость интернета у меня 256.
  • 0

#3 Алексей Соколов

Алексей Соколов
    Topic Starter
  • Пользователь
  • 4 сообщений
  • Репутация: 0

Отправлено 04 Июнь 2009 - 10:26

Можно назвать это белыми пикселями. Но в оригинале на картинке их нет! Они проявляются при использовании скрипта и именно в IE.


  • 0

#4 Евгений

Евгений
  • Пользователь
  • 481 сообщений
  • Репутация: 0

Отправлено 04 Июнь 2009 - 10:38

вас тормоза не смущают? мне лично пофиг было на белые точки) увидев такие тормоза сразу захотелось закрыть страницу.
Скриптов для слайд шоу по моему дофига и больше, не работает этот, юзайте другой :)
  • 0

#5 Алексей Соколов

Алексей Соколов
    Topic Starter
  • Пользователь
  • 4 сообщений
  • Репутация: 0

Отправлено 04 Июнь 2009 - 10:55

Не знаю, я у себя даже дома на тормозном инете тормозов не ощутил.
А вот точки клиент может расценить, как брак или что--то подобное. Поэтому от них лучше избавляться.... только вот как...
  • 0

#6 yury

yury
  • Пользователь
  • 629 сообщений
  • Репутация: 176

Отправлено 04 Июнь 2009 - 10:55

Я вот, например, не увидел ни артефактов ни тормозов :) куда смотреть-то?
Единственный глюк(?) - в ие7 картинки в слайд-шоу как-то не очень приятно подмигивают при смене кадра.
В опере и лисе такой фамильярности не наблюдается.
  • 0

#7 Алексей Соколов

Алексей Соколов
    Topic Starter
  • Пользователь
  • 4 сообщений
  • Репутация: 0

Отправлено 04 Июнь 2009 - 10:58

Да я щас разные скрипты пробую... Подмигивание убрал... точки остались.
Белые точки (пиксели) прямо скоплениями на темных пиджаках.
  • 0

#8 yury

yury
  • Пользователь
  • 629 сообщений
  • Репутация: 176

Отправлено 04 Июнь 2009 - 11:43

Алексей Соколов,
фих его знает, я в жаваскрипте не большой спец, на проблемную тему слышал только, что с прозрачностью в разных браузерах не все гладко.
От себя могу только посоветовать неплохую библиотеку готовых скриптов на динамикдрайве, например такой Swiss Army Image Slideshow вроде неплох.
Ну или подождать, вдруг кто поопытнее решит покопаться в коде вашего слайдшоу
  • 0

#9 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 04 Июнь 2009 - 18:51

Алексей Соколов, проблема точно с прозрачностью в IE. У вас используется фильтр

filter:progid:DXImageTransform.Microsoft.alpha(opacity=10)

возможно тут проблемы.

Слишком много всяких прозрачностей используется для разных браузеров, разобраться в чём проблема сложно.

Посмотрите вашу картинку в photoshop. Возможно некоторые пиксеи имеют некоторую прозрачность, тогда возможнго скрипт не справляется с подобным именно в IE.
  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85


Оформление форума – IPBSkins.ru