Перейти к содержимому



Капча плагинов и MySQL

#1 Xap

Xap
  • Пользователь
  • 1 520 сообщений
  • Репутация: 0
0

Отправлено 27 Январь 2009 - 19:54

Такая ситуация. После переноса сайта на новый хостинг в компоненте комментариев пропала капча. Пропала везде, поставил новый компонент галереи, все равно нет.

 

 

  • 0

#2 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 28 Январь 2009 - 20:47

Базы данных тут не причём, капча генерируется скриптом на автомате. Пропасть она могла из-за прав на файлы шрифтов и бекграундов. Всё зависит от капчи. Возможно просто при переносе не всё перенесли, очень даже возможно, что нарушен файл формирования капчи.

Дай ссылку на страницу с комментариями
  • 0

#3 Xap

Xap
    Topic Starter
  • Пользователь
  • 1 520 сообщений
  • Репутация: 0

Отправлено 28 Январь 2009 - 21:24

Адрес сайта тот же. Там есть галерея фоток. Вот когда нажимаешь на фотку (там кстати может вылетать проблема, описанная мной в другой теме) и там появляется средний эскиз под которым и находится форма для коммента.
  • 0

#4 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 28 Январь 2009 - 21:37

В вашем случае именно не работает скрипт формирования CAPTCHA, из-за чего мне кажется это уже ошибки в галерее, я так понял это не общая капча JOOMLA а именно скрипта галереи
  • 0

#5 Xap

Xap
    Topic Starter
  • Пользователь
  • 1 520 сообщений
  • Репутация: 0

Отправлено 28 Январь 2009 - 21:50

Нет, есть компонент jcomments. Он отвечает за выдачу комментариев. В настройках галереи я просто прописал, что использовать комментарии, но почему-то оно не работает.
  • 0

#6 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 28 Январь 2009 - 21:58

А не в галерее у вас капча работает? Например в новостях? Там же тоже jcomments подключен
  • 0

#7 Xap

Xap
    Topic Starter
  • Пользователь
  • 1 520 сообщений
  • Репутация: 0

Отправлено 28 Январь 2009 - 22:11

У меня просто сложно найти, где комменты работают, поэтому пока не знаю, сейчас посмотрю.
  • 0

#8 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 28 Январь 2009 - 22:13

Так получается нигде не работают из-за капчи? Если да, то это проблема с модулем комментариев, заново его надо будет перезалить.
  • 0

#9 Xap

Xap
    Topic Starter
  • Пользователь
  • 1 520 сообщений
  • Репутация: 0

Отправлено 28 Январь 2009 - 22:37

Да, это косяк компонента. Он тупо перестал работать на сайте, хотя в галерее вот таким образом отображается ;) А если я удалю компонент и поставлю новый, старые комменты не удаляться?
  • 0

#10 Xap

Xap
    Topic Starter
  • Пользователь
  • 1 520 сообщений
  • Репутация: 0

Отправлено 28 Январь 2009 - 22:57

Вроде решил. Честно говоря, я не знаю как решил. но вот здесь _http://joomlaforum.ru/index.php/topic,50052.0.html человек описывает похожую ситуацию. Там советуется ввести строку в браузер. Я ввел, потыкал и заработало, правда что-то не все комментарии отобразились, но зато все остальное заработало.
  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85


Оформление форума – IPBSkins.ru