Перейти к содержимому



Что неправильно настроено в роботс? подскажите пожалуйста

#1 Ивица

Ивица
  • Пользователь
  • 46 сообщений
  • Репутация: 0
0

Отправлено 06 Апрель 2016 - 12:16

Здравствуйте.

помогите пожалуйста в правильной настройке роботс.

Суть: сайт англ. язык

Шаблон настроен путем плагина.

 

при создании sitemap сервис выдает ошибки в неправильном перенаправлении.

 

следующего плана:

 

 

 

_http://www.111111111...l?replytocom=11 вызов из _http://www.111111111111.html причина:robots.txt

Не указан размер страницы в заголовке
Сервер не возвращает в заголовке время изменения страницы

 

 

еще иногда выбивает что после url идет /ru

я думаю в этом причина, как правильно это настроить?

сайт на одном языке (англ). русской версии нет.

помогите пожалуйста это устранить?

 


 

 

  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85
Советую обратить внимание на следующее:
  1. Можно ли в robots.txt указывать несколько sitemap?
  2. Robots.txt - что такое и как им правильно пользоваться
  3. Правильный ROBOTS.TXT для Битрикса
  4. Составление файла robots.txt
  5. Некорректно настроено отображение несуществующих файлов и страниц

#2 BLIK

BLIK
  • Супермодератор
  • 3 491 сообщений
  • Репутация: 725

Отправлено 06 Апрель 2016 - 12:43

Шаблон настроен путем плагина.

Возможно в плагине установить Английский как главный(по умолчанию) и тогда не будет перенаправления на ru? 

P.s И если есть настройки то отключить локализацию на другие языки и оставить только Английский.

 

Ну и сам движок установить(в настройках выбрать язык) локализацию Английский.


  • 0


#3 Ивица

Ивица
    Topic Starter
  • Пользователь
  • 46 сообщений
  • Репутация: 0

Отправлено 06 Апрель 2016 - 12:56

все поправил. удалил вообще русский.

 

проверяю сайтмеп все одно высвечивает 41 ошибку.

Прикрепленные изображения

  • скрин.JPG

  • 0

#4 BLIK

BLIK
  • Супермодератор
  • 3 491 сообщений
  • Репутация: 725

Отправлено 06 Апрель 2016 - 13:06

@Ивица,Где чикбоксы с поле модификации внизу, попробуй поставить по умолчанию, последний чикбокс.

 

P.s Я впервые вижу этот плагин и настройки, поэтому могу ошибаться. 


  • 0



Оформление форума – IPBSkins.ru