Перейти к содержимому



Некорректно отображаются русские буквы

#1

Поделиться сообщением #1



efros

efros
  • Пользователь
  • 317 сообщений
  • Репутация: 18
0

Отправлено 13 Ноябрь 2015 - 19:53

Здравствуйте, в шаблоне у меня есть английские надписи, когда попробовал их переименовать, то вместо перевода отображаются ромбики (если зайти в категорию Ламинат, то вверху это видно), также пробовал переименовать More (т. е. читать далее), но ситуация повторилась, вместо перевода одни ромбы. Читал про это, это вроде кодировка не та, но в хостинге стоит UTF-8, это нужно что-то в шаблоне делать. Заранее благодарен за ответы. Сайт http://www.polochek.ru


 

 

Сообщение отредактировал efros: 13 Ноябрь 2015 - 19:54

  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85
Советую обратить внимание на следующее:
  1. Крякозябры вместо русских символов
  2. Не отображается русский шрифт после импорта базы данных
  3. Ошибка отображения русских букв на сайте
  4. Гугл некорректно отображает страницы сайта
  5. Некорректное отображение описание сайта в поиске

#2

Поделиться сообщением #2



ShowPrint

ShowPrint
  • Пользователь PRO
  • 2 214 сообщений
  • Репутация: 571

Отправлено 13 Ноябрь 2015 - 20:07

@efros вообще-то правильное задание кодировки мета-тегом выглядит так:

<meta http-equiv='content-type' content='text/html; charset=UTF-8'> 

а не так как указано у Вас в коде: <meta charset="UTF-8">

 

По крайней мере "меня так учили"... =)


Сообщение отредактировал ShowPrint: 13 Ноябрь 2015 - 20:08

  • 0
MasterWEBS: третий дом - моё хобби и увлечение... Второй дом: работа - не меньше 12 часов в день...
Первый дом - под охраной: "Осторожно - злая жена!" (дрессировалась долго и надёжно) /*ссылку не просите - не дам!*/


#3

Поделиться сообщением #3



BLIK

BLIK
  • Супермодератор
  • 3 591 сообщений
  • Репутация: 766

Отправлено 13 Ноябрь 2015 - 20:17

@efros,Когда был переведн документ(файл) его нужно сохранять в кодировки UTF8 без BOM. 

 

При сохрании перевденного документа в какой кодировки сохранено?

 

Надо на компе темы файла где перевод смотреть, думаю что кодировка не правильная после перевода.


  • 0

Sign Up  bonus 100$ в фарма ПП Skype: cristina.rx2, ICQ: 676017111, Jabber: cristina.rx@jabb3r.org | Качественный хостинг



#4

Поделиться сообщением #4



efros

efros
    Topic Starter
  • Пользователь
  • 317 сообщений
  • Репутация: 18

Отправлено 13 Ноябрь 2015 - 20:20

@BLIK, дело в том, что там, где категория, оно само изначально так выводит, там ничего не трогал. 

@ShowPrint,А это вы где нашли, можно путь узнать туда? 


  • 0

#5

Поделиться сообщением #5



BLIK

BLIK
  • Супермодератор
  • 3 591 сообщений
  • Репутация: 766

Отправлено 13 Ноябрь 2015 - 20:23

@efros,Возможно когда ты искал как убрать копирайт и шерстил редактором, он файлы по умолчанию сохранил в не в той кодировки. Просто проверь кодировку файлов которые загружал после удаления копирайтов.

 

P.s Вчера вроде проблемы такой не было. 


  • 0

Sign Up  bonus 100$ в фарма ПП Skype: cristina.rx2, ICQ: 676017111, Jabber: cristina.rx@jabb3r.org | Качественный хостинг



#6

Поделиться сообщением #6



ShowPrint

ShowPrint
  • Пользователь PRO
  • 2 214 сообщений
  • Репутация: 571

Отправлено 13 Ноябрь 2015 - 20:49

@efros, загрузил страницу и посмотрел код (Ctrl+U)...

 

В принципе согласен с @BLIK: первое что нужно проверить это кодировку файлов которые правили и закачивали заново... /* сам 3 минуты назад на такой же мине "подорвался" */


  • 0
MasterWEBS: третий дом - моё хобби и увлечение... Второй дом: работа - не меньше 12 часов в день...
Первый дом - под охраной: "Осторожно - злая жена!" (дрессировалась долго и надёжно) /*ссылку не просите - не дам!*/


#7

Поделиться сообщением #7



efros

efros
    Topic Starter
  • Пользователь
  • 317 сообщений
  • Репутация: 18

Отправлено 14 Ноябрь 2015 - 09:27

@BLIK,@ShowPrint, Поставил чистую эту тему, проблема так и есть, значит это с темой что-то 

 

Вот удалил этот код и вообще убрал то меню, а то как это исправить не знаю. 

 

<div id="loop_meta_wrapper">

  <div class="container_16 clearfix">
    <div id="loop-meta" class="grid_16">
      <h1 class="loop-meta-title"><?php printf( __( 'Category Archives: %s', 'contango' ), '<span>' . ucwords( strtolower ( single_cat_title( '', false ) ) ) . '</span>' ); ?></h1>
      <div class="loop-meta-description"><?php echo category_description(); ?></div>
    </div> <!-- end #loop-meta -->
  </div> <!-- end .container_16 -->
</div>

Сообщение отредактировал efros: 14 Ноябрь 2015 - 09:57

  • 0

#8

Поделиться сообщением #8



ShowPrint

ShowPrint
  • Пользователь PRO
  • 2 214 сообщений
  • Репутация: 571

Отправлено 14 Ноябрь 2015 - 10:57

проблема так и есть
Ну сейчас-то вроде всё нормально...

 

Ромбики - однозначно проблема кодировки, всегда проверяйте чтоб файлы, которые правите, записывались в utf8... Бывает забудешь проверить, запишешь в ansi, и "вот они родные" ромбы...

По настройкам в движках - ничего не скажу, не знаком, это к Александру... "Освежил" инфу об установке кодировки через meta, в  html5 действительно допускается такая запись, так что с этим всё в порядке...

Если есть проблемы "с ромбиками" - проверяйте файлы...


  • 0
MasterWEBS: третий дом - моё хобби и увлечение... Второй дом: работа - не меньше 12 часов в день...
Первый дом - под охраной: "Осторожно - злая жена!" (дрессировалась долго и надёжно) /*ссылку не просите - не дам!*/


#9

Поделиться сообщением #9



Blogger

Blogger
  • Неактивные
  • 58 сообщений
  • Репутация: 7

Отправлено 18 Ноябрь 2015 - 10:44

Когда редактируете какой либо файл в котором до Вашего вмешательства не было символов на кириллице, то предварительно нужно выбирать кодировку utf8 без BOM до того как начинаете вбивать символы на киррилице так как обычно такие файлы в кодировке просто utf8. И работать надо с текстовым редактором который корректно это делает, я использую Notepad++ проблем никогда не было.


  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85


Оформление форума – IPBSkins.ru