Перейти к содержимому



Проблемы с выводом rss

#1

Поделиться сообщением #1



iisus13

iisus13
  • Неактивные
  • 9 сообщений
  • Репутация: 0
0

Отправлено 17 Июнь 2013 - 08:10

в rss выводятся только названия постов и миниатюры но уже в полном формате, текста нет сосвсем на попытки изменить что-то со стороны вп лента не реагирует совсем, только на количество выводимых постов, на плагины ноль эмоций. У кого-нибудь были подобные проблемы?

 

 

  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85
Советую обратить внимание на следующее:
  1. Поиск по сайту. Проблема с выводом результатов.
  2. Повышаем эффективность RSS-ленты
  3. [HELP] проблема с отображением сайта.
  4. Нужна ли на сайте RSS-лента ?
  5. Проблема с выводом краткой новости Вордпресс

#2

Поделиться сообщением #2



Sosnovskij

Sosnovskij
  • Администратор
  • 4 106 сообщений
  • Репутация: 618

Отправлено 17 Июнь 2013 - 11:23

Установлены ли какие-нибудь плагины или хуки, отвечающие за вывод или представление rss-ленты?
  • 0

Не стесняйтесь ставить оценки темам :) Правила форума. Мой блог http://sosnovskij.ru/.



#3

Поделиться сообщением #3



iisus13

iisus13
    Topic Starter
  • Неактивные
  • 9 сообщений
  • Репутация: 0

Отправлено 17 Июнь 2013 - 16:10

FD Feedburner Plugin и все. Устанавливал ozh-better-feed, переустановил но его как будьто совсем нет. В код не лазил т.к в РНР слабоват да и вразумильных решений своей проблемы не обнаружил. Смотрел исходный код выводимой страницы через оперу <description> отсутствуе и есть строчка <content:encoded /> , кодировка utf-8. Можешь ленту посмотреть http://feeds.feedbur...m/gazeta45/mccA. В идеале хотел чтобы была в формате Яндекс. Ленты.
  • 0

#4

Поделиться сообщением #4



Sosnovskij

Sosnovskij
  • Администратор
  • 4 106 сообщений
  • Репутация: 618

Отправлено 17 Июнь 2013 - 16:33

iisus13, конфликта с этим плагином нет?
  • 0

Не стесняйтесь ставить оценки темам :) Правила форума. Мой блог http://sosnovskij.ru/.



#5

Поделиться сообщением #5



iisus13

iisus13
    Topic Starter
  • Неактивные
  • 9 сообщений
  • Репутация: 0

Отправлено 17 Июнь 2013 - 16:46

как это узнать?

скорее всего нет новости на ленту перенаправляются (оставил только один плагин FD Feedburner Plugin) может проблема в файле вывода rss:
<?php
/**
* RSS 0.92 Feed Template for displaying RSS 0.92 Posts feed.
*
* @package WordPress
*/
header('Content-Type: ' . feed_content_type('rss-http') . '; charset=' . get_option('blog_charset'), true);
$more = 1;
echo '<?xml version="1.0" encoding="'.get_option('blog_charset').'"?'.'>'; ?>
<rss version="0.92">
<channel>
<title><?php bloginfo_rss('name'); wp_title_rss(); ?></title>
<link><?php bloginfo_rss('url') ?></link>
<description><?php bloginfo_rss('description') ?></description>
<lastBuildDate><?php echo mysql2date('D, d M Y H:i:s +0000', get_lastpostmodified('GMT'), false); ?></lastBuildDate>
<docs>http://backend.userland.com/rss092</docs>
<language><?php bloginfo_rss( 'language' ); ?></language>
<?php do_action('rss_head'); ?>
<?php while (have_posts()) : the_post(); ?>
<item>
  <title><?php the_title_rss() ?></title>
  <description><![CDATA[<?php the_excerpt_rss() ?>]]></description>
  <link><?php the_permalink_rss() ?></link>
  <?php do_action('rss_item'); ?>
</item>
<?php endwhile; ?>
</channel>
</rss>

  • 0

#6

Поделиться сообщением #6



html-ka

html-ka
  • Неактивные
  • 455 сообщений
  • Репутация: 82

Отправлено 17 Июнь 2013 - 16:50

а в настройках самого wordpress, что делал, там целый раздел есть
могу порекомендовать несколько статей
http://ktonanovenkog...ry-chast-3.html
http://ktonanovenkog...ry-chast-2.html
  • 0

#7

Поделиться сообщением #7



iisus13

iisus13
    Topic Starter
  • Неактивные
  • 9 сообщений
  • Репутация: 0

Отправлено 17 Июнь 2013 - 16:52

сейчас все попробуем, скорее всего ошибка в файлах вп
  • 0

#8

Поделиться сообщением #8



iisus13

iisus13
    Topic Starter
  • Неактивные
  • 9 сообщений
  • Репутация: 0

Отправлено 17 Июнь 2013 - 18:05

мой случай не попадает под эту статью, эта статья для тех у кого сразу после установки все заработало, у меня сам сервис тоже работает но текст не выводится и все тут, лишь изображения, которое я добавил как миниатюры для постов, они почему то заключены в <description> , а то что я пишу в поле description плагина Platinum SEO игнорируется
  • 0

#9

Поделиться сообщением #9



iisus13

iisus13
    Topic Starter
  • Неактивные
  • 9 сообщений
  • Репутация: 0

Отправлено 17 Июнь 2013 - 18:44

Люди денег дам кто решит мою проблему, второй день не сплю, головой бьюсь о стену кирпичную.
  • 0

#10

Поделиться сообщением #10



html-ka

html-ka
  • Неактивные
  • 455 сообщений
  • Репутация: 82

Отправлено 17 Июнь 2013 - 18:59

кинь в личку доступ
  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85


Оформление форума – IPBSkins.ru