Перейти к содержимому



Fatal error очень нужна помощь

#1 Эдуард

Эдуард
  • Пользователь
  • 5 сообщений
  • Репутация: 0
0

Отправлено 09 Март 2013 - 09:25

Доброе время ,очень нужна помощь.
Перейду к проблеме, пытаюсь установить движок на хостинг SMART CART который ранее устанавливал без проблем ,
а сейчас при установке выдает вот такую ошибку:
 

Fatal error: Incompatible file format: The encoded file has format major ID 3, whereas the Loader expects 4 in /home/qwert14k/public_html/core/functions.main.php on line 0

На сервере установлен php 5.3 + Zend Guard Loader v3.3
Они доступны для использования и включены
Так в чем же может быть дело?????


 

 

  • 0

#2 yury

yury
  • Пользователь
  • 629 сообщений
  • Репутация: 176

Отправлено 09 Март 2013 - 11:13

Эдуард, проверьте системные требования к вашей CMS (к движку). Скорее всего, она не совместима с PHP 5.3.
Т.е. вам нужен
* либо хостинг с PHP 5.2 и ниже
* либо более новая версия вашей CMS, которая понимает PHP 5.3 и выше
  • 0

#3 Эдуард

Эдуард
    Topic Starter
  • Пользователь
  • 5 сообщений
  • Репутация: 0

Отправлено 09 Март 2013 - 12:45

Ситуация такова что месяц назад я устанавливал этот движок и все было нормально) а пару дней назад он перестал работать и вывел мне ошибку 500,
ну я снес сайт и решил повторно установить CMS и все не хочет .

Системные требования к хостингу:

- Zend Optimizer 3.3.7 и выше
- PHP 5.2.x и выше
- Mysql версии 5 и выше
- mod_rewrite
- fopen и file_get_contents (с доступом к внешним ресурсам), safe_mode off, short_open_tag On
- модули для PHP: gd2, session, XSL, DOM, XML, PDO (pdo_mysql), ICONV, MBSTRING, JSON.

Сам хостинг :
PHP 5.2.1
Zend Guard Loader

Админы мне написали что 500 ошибка возникает из-за этих 2-х правил:
RewriteRule ^$ /webroot/ [QSA,L]
RewriteRule (.*) /webroot/$1 [QSA,L]
  • 0

#4 yury

yury
  • Пользователь
  • 629 сообщений
  • Репутация: 176

Отправлено 09 Март 2013 - 15:06

Сам хостинг :
PHP 5.2.1
Zend Guard Loader

Админы мне написали что 500 ошибка возникает из-за этих 2-х правил:
RewriteRule ^$ /webroot/ [QSA,L]
RewriteRule (.*) /webroot/$1 [QSA,L]

Это уже про другой сервер и другую ошибку? (раньше вы писали, что "На сервере установлен php 5.3" )

Если админы грешат на эти строки + Ошибка 500, то первое что приходит в голову — это уточнить
* действительно ли у вас корень сайта лежит в папке с названием webroot?
* правильные ли права установлены на файлы и папки? (должно быть rwxr-xr-x 0755 для папок и rw-r--r-- 0644 для файлов)
  • 0

#5 Эдуард

Эдуард
    Topic Starter
  • Пользователь
  • 5 сообщений
  • Репутация: 0

Отправлено 09 Март 2013 - 20:50

В общем перепробовали все что можно было( я в растеряности ,выдает вот такую вещь:
Фатальная ошибка: Несовместимый формат файла: У закодированного файла есть формат главное удостоверение личности 3, тогда как Погрузчик ожидает 4 в/home/qwert14k/public_html/vsem-comfort.ru/core/functions.main.php на линии 0

И что может быть даже разработчики скрипта не знают не говоря уж об админах сервера.
  • 0

#6 Эдуард

Эдуард
    Topic Starter
  • Пользователь
  • 5 сообщений
  • Репутация: 0

Отправлено 09 Март 2013 - 21:43

Уважаемый Админ и Модератор с Вашего позволения)
Уважаемые веб мастера хочу обьявить конкурс ) кто первый поможет мне устранить эту проблему тому перечислю на веб мани маленький приз в размере 300р :)
  • 0

#7 Mr.Developer

Mr.Developer
  • Пользователь
  • 73 сообщений
  • Репутация: 12

Отправлено 11 Март 2013 - 16:44

Посмотрите вот здесь второй пост (http://forums.zend.c...hp?f=57&t=42683).
Видимо вам нужен дистрибутив закодированный зендом с настройками под php 5.3
  • 0

#8 Эдуард

Эдуард
    Topic Starter
  • Пользователь
  • 5 сообщений
  • Репутация: 0

Отправлено 11 Март 2013 - 22:04

посмотрим)
  • 0

robot

robot
  • Пользователь PRO
  • 2 652 сообщений
  • Репутация: 85


Оформление форума – IPBSkins.ru