Перейти к содержимому

Сервис обмена электронных валют

Партнерская программа Kredov

Вопрос по программирыванию

#1 sk8er

sk8er
  • Неактивированные
  • 128 сообщений
  • Репутация: 0
0

Отправлено 12 Сентябрь 2008 - 11:32

Помогите мне немного подправить код. В файле который отвечает за голосования не отображаются названия. Из-за чего такое может быть? Вот код этого файла(названия я выделил):

[votelist]
<!-- Voting question start -->
<table width="100%" border="0" cellpadding="0" cellspacing="0">
<tr>
<td align="left"><strong>{title}</strong></td>
</tr>
</table>
<!-- Voting question end -->
<br />
<!-- Voting answers start -->
<form method="post" name="vote" action=''>{list}
<table width="100%" cellpadding="0" cellspacing="0" border="0">
<tr>
<td width="25" align="left"><img src="{THEME}/images/spacer.gif" width="25" height="1" /></td>
<td align="left"><input type="hidden" name="vote_action" value="vote" />
<input type="hidden" name="vote_id" id="vote_id" value="1" />
<input type="submit" onclick="doVote('vote'); return false;" class="bbcodes_poll" value="Голосовать" /></td>
</tr>
</table>
</form>
<!-- Voting answers end -->
<!-- Voting results start -->
<form method="post" name="vote_result" action=''>
<table width="100%" border="0" cellpadding="0" cellspacing="0">
<tr>
<td align="left" width="20"><img src="{THEME}/images/spacer.gif" width="1" height="3" /></td>
<td align="left"><img src="{THEME}/images/spacer.gif" width="1" height="3" /></td>
</tr>
<tr>
<td width="25" align="left"><img src="{THEME}/images/spacer.gif" width="25" height="1" /></td>
<td align="left"><input type="hidden" name="vote_action" value="results" />
<input type="hidden" name="vote_id" value="1" />
<input type="submit" onclick="doVote('results'); return false;" class="bbcodes_poll" value="Результаты" /></td>
</tr>
</table>
</form>
<!-- Voting results end -->
[/votelist]
[voteresult]
<!-- Voting question start -->
<table width="100%" border="0" cellpadding="0" cellspacing="0">
<tr>
<td align="left"><strong>{title}</strong></td>
</tr>
</table>
<!-- Voting question end -->
<br />
<!-- Voting answers start -->
<table width="100%" cellpadding="0" cellspacing="0" border="0">{list}
</table>
<!-- Voting answers end -->
<!-- Summary start -->
<table width="100%" border="0" cellpadding="0" cellspacing="0">
<tr>
<td align="left"><br /><strong>Всего проголосовало:</strong> {votes}</td>
</tr>
</table>
<!-- Summary end -->
[/voteresult]

 

 

  • 0

#2 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 13 Сентябрь 2008 - 00:55

<!-- Voting answers start -->
<table width="100%" cellpadding="0" cellspacing="0" border="0">{list}
</table>
<!-- Voting answers end -->

Читаем и осознаём что здесь не так! Если не понятно спрашиваем!
  • 0

#3 sk8er

sk8er
    Topic Starter
  • Неактивированные
  • 128 сообщений
  • Репутация: 0

Отправлено 13 Сентябрь 2008 - 11:19

Не понятно( Объясни пожалуйсто.... Тока именно объясни, чтоб понятно было, мне-же интересно от чего это)
  • 0

#4 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 13 Сентябрь 2008 - 18:53

Либо дело не в шаблоне, а просто {list} является пустым
Либо дело в том что надо ещё прописывать <tr> и <td>, хотя это не точно, всё зависит от того, что хранится в $list перед отправкой в шаблон.
Иначе я даже и знать не могу, что ещё может быть! Больше склоняюсь к первому варианту!

Особенно если вы добавляли скрипт вручную, то вам надо было добавлять код в файлы, вот там может и напортачили...
  • 0

#5 sk8er

sk8er
    Topic Starter
  • Неактивированные
  • 128 сообщений
  • Репутация: 0

Отправлено 13 Сентябрь 2008 - 20:01

Я ничего не мог напортачить. Просто когда я поставил новый шаблон на движок(DLE) заметил этот косяк.
А может там заместо {list} нужно что-то прописать?
Если нужно посмотреть как эта ошибка выглядит зайди на сайт в моей подписи, там увидиш раздел Опрос, вот там то и будут белые кнопки.
  • 0

#6 ZiTosS

ZiTosS
  • Пользователь
  • 5 148 сообщений
  • Репутация: 8

Отправлено 14 Сентябрь 2008 - 09:49

Вы вообще про какие названия? Вроде опросник работает нормально. Просто у вас у кнопок, как я понял, цвет шрифта совпадает с цветом фона, а так всё работает. Вам надо зайти в папку с действующим стилем и поменять в файле с CSS стиль кнопок. Они могут бытьь просто как input, либо оформление привязано к определённому классу .class

Что меня ещё поразило, у вас очень много ошибок при подключении к базе данных. У вас скрипт-то вообще рабочий?
В самом верху выводит очень много ошибок по запросам к БД. А всё из-за неправильного подключения! Вы что-то напутали, вот и ошибки при работе с БД. Но эти ошибки не влияют на оформление опросника.
Ошибки не стал сюда вставлять. Это слишком небезопасно и советую вам как можно быстрее их исправить!
  • 0

#7 sk8er

sk8er
    Topic Starter
  • Неактивированные
  • 128 сообщений
  • Репутация: 0

Отправлено 14 Сентябрь 2008 - 15:46

Ошибки? Где? у меня в браузере всё нормально... Можеш мне в личку кинуть?
  • 0


Оформление форума – IPBSkins.ru